1.0.0pre1 branch now available via git

In preparation for our 1.0.0 release, we’ve prepared a stable branch in git that people can try. Nearly all of the functionality is complete for the release, but the examples and documentation need to be completed before the final release and are not part of this snapshot. Therefore the examples do not show some of the new functionality available, such as the big expansion in asset classes available. To get a full open source release:

  1. `git clone git://github.com/OpenGamma/OG-Platform.git`
  2. `cd OG-Platform`
  3. `ant init`
  4. `ant clone-or-pull`
  5. `ant checkout -Dgit.branch=dev/stable`
  6. `ant clean publish-all-local`
  7. `cd projects/OG-Examples`
  8. `ant new-hsqldb`
  9. `ant demo-database`
  10. `ant jetty-debug or ant jetty`
  11. You'll need to wait a while for the server to start. If you use jetty-debug, you should see `========= JETTY START COMPLETE =========` when the server is ready to accept browser requests.
  12. Point your browser at http://localhost:8080
Please note also that this snapshot is not officially supported and has not been extensively tested. We're finishing the final work on 1.0.0, and will be formally releasing it as soon as finishing touches are done.

I religiously followed above steps
On first run the page redirected and gave a "Server not found"
After N trials this it came to the Loading page and got stuck.
This was what found in the jetty logs - https://gist.github.com/1664321

Any pointers please !!!


Sorry to hear you’re having problems. I suspect it could just be that you’re not waiting long enough before pointing a browser at the server - the server takes a while before it starts responding to http requests, particularly if you’re using a laptop or system with less memory. I’ll edit the post to make it clearer, sorry about that.

The errors I can see in the gist you included admittedly look like problems, but aren’t actually anything to worry about - they’re primarily functions failing during the initialisation phase because we haven’t yet included example configuration entries in the config database for things like FX and equity option volatility surfaces.

try running the final step using

ant jetty-debug

rather than ‘ant jetty’ and then wait until you see

========= JETTY START COMPLETE =======

(not just JETTY START BEGINS) before pointing your browser at http://localhost:8080

If that doesn’t work, please get back to us.

I’ve just double-checked and I do seem to be seeing a different problem. Let me investigate further.

So, I’ve just seen an issue where on the Analytics ‘tab’ there are no views listed in the drop-down (there should be 3 at the moment). This may have been due to my local Eclipse setup on a different branch interfering with my testing of the stable branch, or something else. I fixed the problem by re-running the
ant new-hsqldb
ant demo-database
steps (after killing the server with if you’re using ant jetty-debug or ant jetty-stop if you used the plain ant jetty launch task. I’m doing some further testing to see if my issue was a one-off local problem or something that might affect external users.

Ok, false alarm on my part as far as I can tell - I can’t reproduce the problem, I think it was my development environments interfering.

Thanks Jim ,
Though most of the error message havnt dissapeared , the link is alive and working properly.


thanks for the clear steps for the build.
it was the first time i tried to build opengamma.
I followed the steps blindly and precisely on several machines with different success.

On my mac mini 8GB RAM and wired internet connection, everything worked first time and saw I opengamma, perfect!!

On my windows 7 laptop, 4GB RAM and wireless internet connection, it was not so smooth. I executed the steps via cygwin and the build repeatedly stuck at random points during step 7. After maybe 10 manual restarts of the build it did finally make it to the end and the build completed.

On my old linux laptop, 4GB RAM, Ubuntu 11.04 wireless internet connection, the build just got stuck at a particular point in step 7, with an error similar that found in the FAQ section. Details below.

Unfortunately, i didnt have much more time to investigate the cause of the stickiness in step 7, moreover i have not used ivy before, so I dont have good guesses, other than memory or reliability of the internet connection.


[ivy:resolve] [SUCCESSFUL ] org.fudgemsg#fudge-proto;0.3-local-20120121161257!fudge-proto.jar (36ms)
[ivy:resolve] :: resolution report :: resolve 4428ms :: artifacts dl 121ms
[ivy:resolve] :: evicted modules:
[ivy:resolve] org.apache.commons#commons-codec;1.4 by [org.apache.commons#commons-codec;1.5] in [default]
[ivy:resolve] org.slf4j#slf4j;1.5.11 by [org.slf4j#slf4j;1.6.1] in [default]
[ivy:resolve] org.springframework#spring;2.5.6 by [org.springframework#spring;3.0.4] in [default]
[ivy:resolve] org.antlr#antlr;2.7.7 by [org.antlr#antlr;3.3] in [default]
| | modules || artifacts |
| conf | number| search|dwnlded|evicted|| number|dwnlded|
| default | 61 | 22 | 1 | 4 || 125 | 1 |
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve] [NOT FOUND ] org.springframework#spring;3.0.4!spring-test.jar (0ms)
[ivy:resolve] ==== shared: tried
[ivy:resolve] /ogdev/OG-PrivateIvy/public_html/org.springframework/spring/3.0.4/spring-test-3.0.4.jar
[ivy:resolve] /ogdev/OG-PrivateIvy/public_html/org.springframework/spring/3.0.4/spring-test-src-3.0.4.jar
[ivy:resolve] /ogdev/OG-PrivateIvy/public_html/org.springframework/spring/3.0.4/spring-test-javadoc-3.0.4.jar
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] :: FAILED DOWNLOADS ::
[ivy:resolve] :: ^ see resolution messages for details ^ ::
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] :: org.springframework#spring;3.0.4!spring-test.jar
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::

/home/gary/OG-Platform/build.xml:103: The following error occurred while executing this line:
/home/gary/OG-Platform/build.xml:90: The following error occurred while executing this line:
/home/gary/OG-Platform/common/common-ivy.xml:57: impossible to resolve dependencies:
resolve failed - see output for details

Total time: 28 seconds
gary@kennedyT61p:~/OG-Platform$ java -version
java version "1.6.0_26"
Java™ SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot™ Server VM (build 20.1-b02, mixed mode)
gary@kennedyT61p:~/OG-Platform$ ant -version
Apache Ant version 1.8.1 compiled on October 13 2010
gary@kennedyT61p:~/OG-Platform$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

Hi Gary,

Ivy is a bit sensitive about network connection the first time you run it as it populates the ivy cache. This is made worse by it carrying on after a download failure - we’re investigating a way to make it more robust. Try running an

ant clean-ivy-cache

and building again and let us know if you continue having trouble.


I since upgraded my linux laptop to ubuntu 11.10 and tried all the steps again, this time I encountered no problem with ivy.

I did have to edit the build file in projects/OG-Examples. The jetty-properties has a setting for jvm.xmx at 4Gb which was too high for my little laptop, but dropping down to 2GB allowed build to finish and i had opengamma demo running.

Finally i noticed this error message concerning some demo data during step 10.


[java] Starting connections
[java] 10:09:02.136 [main] WARN n.s.e.config.ConfigurationFactory - No configuration found. Configuring ehcache from ehcache-failsafe.xml found in the classpath: jar:file:/home/gary/OG-Platform/projects/OG-Examples/lib/jar/net.sourceforge.ehcache/ehcache/ehcache-core-1.7.2.jar!/ehcache-failsafe.xml
[java] 10:09:08.446 [main] INFO c.o.w.s.DemoCurveFunctionConfiguration - Created repository configuration with 20 curve provider functions
[java] 10:09:08.506 [main] ERROR c.o.e.m.SimulatedHistoricalDataGenerator - Not enough fields in CSV on line 2
[java] 10:09:08.512 [main] ERROR c.o.e.m.SimulatedHistoricalDataGenerator - Not enough fields in CSV on line 505

Ah, yes, we do have the heap size set quite high, which causes problems on people building on laptops. I’ll look into reducing the default for the 1.0 release to try to address that.

When I do this, the command line build is successful. However, I have noticed that the steps do not include setting up the fudge projects - these are required to build the project in eclipse. What is the recommended way to get a correct version of the fudge directories so that the eclipse dependencies are satisfied?

The Fudge directories are automatically cloned/updated by the
ant clone-or-pull
target which is part of the setup process. We’re changing that for 1.0 so fudge will now get pulled in as an external library like most other dependencies. It’s possible that something has been broken during this change though, so I’ll get someone to check.