Ant install error

as reported by the documentation I cloned the git project and then I ran the command ant install, but the task fails reporting the error
common-ivy.xml:57: ivy: resolve doesn’t support the “log” attribute

I think that the problem is due to the fact that attempts to install ivy 2.0.0 beta1 (and the log attribute is availabe from 2.2)

This is the buildlist task output
No ivy:settings found for the default reference ‘ivy.instance’. A default instance will be used
no settings file found, using default…
[ivy:buildlist] :: Ivy 2.0.0-beta1 - 20071206070608 :: ::
:: loading settings :: url = jar:file:/C:/Program%20Files%20(x86)/apache-ant-1.8.2/lib/ivy.jar!/org/apache/ivy/core/settings/ivysettings.xml

If I remove the log attribute
at row 57, the task install seems to run correctly with until exceptions occur at dependency resolution:

:: org.apache.commons#commons-io;2.3: not found
::;3.0: not found
:: org.fudgemsg#fudge-proto; not found
:: org.fudgemsg#fudge-java; not found
:: org.springframework#spring-amqp;1.1.1.RELEASE: not found
:: org.apache.commons#commons-lang;2.6: not found
:: org.json#json;1.0.0.v201011060100: not found
:: org.springframework#spring;3.0.4: not found
:: org.scannotation#scannotation;1.0.2: not found
:: org.postgresql#postgresql-jdbc;[9.0,10.0[: not found
:: com.jolbox#bonecp;0.7.1: not found
:: org.apache.activemq#activemq;5.3.0: not found
::;12.0: not found
:: org.slf4j#slf4j;1.5.11: not found
:: com.sun.jersey#jersey;1.12: not found
:: org.apache.commons#commons-cli;1.2: not found
:: org.mockito#mockito;1.9: not found
:: org.hibernate#hibernate;3.5.2: not found
:: xerces#xercesImpl;2.9.0: not found
:: javax.servlet#servletapi;2.5: not found
:: javax.time#jsr-310-ri;0.6.4: not found

:: ^ see resolution messages for details ^ ::
:: javax.jms#jms;1.1!jms.jar

The problem seems be start at “module not found: org.fudgemsg#fudge-java;” row. Probably the problem is caused by improper access to the repository ivy.
Unfortunately I do not know Ivy (internally use maven) and so I can not identify a clear cause of everything.

Update: the same problem appears with the ivy plugin into Eclipse IDE with “resolve” command.
Update 2: this behavior seems to occur only on Windows 7. The “ant install” task is ok under Osx sl.

Any idea?
Thanks in advance

Marco Bonati

I’ll get someone to investigate this ASAP. We recently changed the way ivy was downloaded/included, so it seems we might have broken something.

Best Regards,


Jim Moores, CTO, OpenGamma Limited, UK.

Can I ask, is it possible you have an old version of ivy (the 2.0.0beta1) installed on your classpath? I can’t see where we’re possibly getting that version from.

Hi Jim
I tried to find a 2.0.0beta1 installation of the ivy (or any other) on my windows workstation, but I have nothing in the classpath.
At the moment I’m working on my mac and all works fine.
As soon as I can try to download the latest version and update my classpath on my windows machine and override the ivy requirement.

Thanks for your interest

best regards