Could not find or load main class com.opengamma.examples.simulated.tool.ExampleDatabaseCreator



I followed carefully each step described in the “Setting Up Eclipse” guide ( In the end, I have several projects on the left of the IDE, including the two example projects.

Then, I try to run the server as described in the documentation :
"To run the examples-simulated server from Eclipse, follow these steps:

  • Find the class com.opengamma.examples.simulated.tool.ExampleDatabaseCreator (use Ctrl+Shift+T on Windows)
  • Run it, by right clicking -> Run As -> Java Application, and wait for it to complete
  • Find the class com.opengamma.examples.simulated.ExamplesSimulatedComponentServerDev
  • Run it, by right clicking -> Run As -> Java Application"

Unfortunately, I get the error message “Could not find or load main class”.

I tried to clean projects, update maven, everything described in the documentation, but still get the same issue.

I’m running Eclipse, brand new workspace, on Mac OSX 10.9.2, with JDK 1.7.

Any tips I could try?




Problem solved by updating Eclipse :slight_smile: