How can I view HSQL database?

I’m new to open Gamma and been trying to access the HSQL database and tables created in the Simulated project with out any avail.

I’ve downloaded RazerSQL and I’ve tried the credentials in

A quick way is to use built-in Swing GUI - change location to suit your installation:
java -cp \OG-Platform\examples\examples-simulated\target\server-dir\lib\hsqldb-2.2.9.jar org.hsqldb.util.DatabaseManagerSwing

Then enter for instance:
Type: HSQL database Engine In-Memory
Driver: org.hsqldb.jdbcDriver
URL: jdbc:hsqldb:file:\OG-Platform\examples\examples-simulated\target\server-dir\data\masterdb\hsqldb\example-db
User: whatever it is…
PassWord: whatever it is…

I can connect now to HSQL inMemory and local, thank you very much. But, I don’t see any tables apart from the system tables.

Where does openGamma store the created tables and how can I view them?

You need make sure your connection URL points to your opengamma database path as in example above (for my case).

:slight_smile: I have correct path, if I enter the path incorrectly it prompts an error message. Still no tables except for system tables.

Have you run the database creation script? I’m not sure which platform you’re using but the tables won’t appear at all until you initialise. It’s called init-examples-simulated-db.[sh|bat].

Just bear in mind that direct manipulation/linking against the schema (apart from the rsk_* schemas) is not supported as we change our schemas from time to time. Ideally any interaction should be through the *Master API interfaces or REST endpoints.

I’m very new to OpenGamma. All I managed to do is get it up and running within IntelliJ on a Linux redhat environment and getting it to work on Windows or in Eclipse was a nightmare for a week.

The script did run within IntelliJ before I started the server. As far as I am aware the database and tables have been created otherwise OpenGamma wouldn’t have started.

All I want to do is view the tables. Would really appreciate any help as its getting really frustrating :frowning:

If you created the database from an IDE the data directory might not be in the same location as it would be if you ran the script from the command line. Can you try this for the URL


You could also search for the example database files by running this in the OG-Platform directory

find . -name ‘example-db*’


Hi Chris
Thanks for the message, I seen the file before and I even created another database with different name and placed it in the data folder but still can not see the tables created :frowning:

Make sure you are logged in with User “OpenGamma” and same password. Then also make sure that “*” is selected in the GUI menu “Schemas”.

Hope this helps. If not you will need to locate your files using find command or similar as suggested above.

Have you tried using an absolute path in the URL?


When I use find . -name ‘example-db*’ I get





I’m assuming absolute path would be

Wow, it works :slight_smile: Thanks very much

At first it was giving me an error message about file locked then I switched off the server and used the absolute path and like magic the tables all appeared :slight_smile:

1 Like