Error launching "ant jetty-debug" from OG-Examples


I’m developing against the head revision and I’m trying to run the jetty-debug ant task from OG-Examples. This was working, but now I get the following output from ant: Unable to find XML Config: /unimportant/OG-Platform/projects/OG-Examples/config/engine-spring.xml
at org.eclipse.jetty.start.main.resolveXmlConfig(

Let me know if you would like the full stack trace. engine-spring.xml is explicitly referenced in OG-Examples/build.xml as well as start-jetty.(bat|sh). ‘find . -name “engine-spring.xml”’ from OG-Platform yields no results. Is it possible that this was missed in a git push?

On an unrelated note, is it possible to allow text formatting in Vanilla to allow better formatting for code snippets/ant output when posting to the forum? I know Bjarne Stroustrup likes using non-fixed-width fonts for code formatting, but I think it looks best monospaced.


I’m currently introducing a whole new config system to master. This has caused various things to break, including the examples jetty-debug task. I’m looking into fixing that at the moment. More documentation will appear on the config rewrite in the next week or so. Stay tuned…


“ant jetty” and “ant jetty-debug” should now be working again with my latest push. Note that both rely on the web-engine directory being located under the OG-Examples directory. If you have a checked out source tree, you need to change “” to “” in the build.xml (I hope to improve this).


I have been trying to run the OG-Examples.
“ant new-hsqldb” command in OG-Examples directory was successfull. but
when I run the command “ant init-database” command I got a message like this

[echo] Stopping Jetty server (stop port 8079)

[java] Invalid maximum heap size: -Xmx4096m
[java] The specified size exceeds the maximum representable size.
[java] Could not create the Java virtual machine.

/home/algotree10/git/OG-Platform/projects/OG-Examples/build.xml:96: Java returned: 1

Total time: 1 minute 7 seconds

my laptop conf. is
ubuntu 11.04


Sorry to say, Myself solved the problem by
editing 32nd line in build.xml into
"property name=“jvm.xmx” value=“1024m” "
anyway thanks for trying on it.

I think the following two files too RAM dependant when run in low configuration

  1. scripts/ MEM_OPTS=${MEM_OPTS:–Xms4096m -Xmx4096m -XX:MaxPermSize=256m}

  2. scripts/ -Xmx4096M \


I think you’re right. The reason they’re like that is that we tend to run more complex configurations than the examples locally on machines with lots of RAM, so it just slipped through into the examples. The Windows installer, for example, uses a percentage of available RAM (although it struggles if you try to run e.g. R, and Engine and Bloomberg in 2GB, which is why we haven’t released a 32-bit installer). I’ve opened and assigned a JIRA issue to fix it for the next point release. Thanks for reporting it!